[SciPy-User] Problems installing scipy 0.10.0 using a local installation of numpy 1.6.1

David Pitchford pitch006@umn....
Wed Nov 23 11:11:58 CST 2011


I am trying to install scipy on a lab computer for research at my
university. I do not have root access to these machines, so when I need to
install new python modules I usually install them locally to a folder I
have control over (using python setup.py build), then add it to my
PYTHONPATH variable. I got numpy 1.6.1 working this way, but when I try to
install scipy 0.10.0 with my PYTHONPATH variable pointing to
build/lib.linux-x86_64-2.6/ (relative to the top-level directory numpy is
in, numpy-1.6.1), I get some errors that appear to involve files and
directories that were expected and not found. Here is part of the output
from my build command:

umfpack_info:
  libraries umfpack not found in /usr/local/lib
  libraries umfpack not found in /usr/lib64
  libraries umfpack not found in /usr/lib
  libraries umfpack not found in /opt/local/lib
/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/distutils/system_info.py:460:
UserWarning:
    UMFPACK sparse solver (http://www.cise.ufl.edu/research/sparse/umfpack/)
    not found. Directories to search for the libraries can be specified in
the
    numpy/distutils/site.cfg file (section [umfpack]) or by setting
    the UMFPACK environment variable.
  warnings.warn(self.notfounderror.__doc__)
  NOT AVAILABLE

non-existing path in 'scipy/spatial':
'/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/core/include'
non-existing path in 'scipy/spatial':
'/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/core/include'
non-existing path in 'scipy/special':
'/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/core/include'
non-existing path in 'scipy/special':
'/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/core/include'
Traceback (most recent call last):
  [Most of long stack trace omitted]
  File
"/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/distutils/npy_pkg_config.py",
line 309, in _read_config
    meta, vars, sections, reqs = parse_config(f, dirs)
  File
"/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/distutils/npy_pkg_config.py",
line 281, in parse_config
    raise PkgNotFound("Could not find file(s) %s" % str(filenames))
numpy.distutils.npy_pkg_config.PkgNotFound: Could not find file(s)
['/export/scratch/pitch/trunk/pyserver/numpy-1.6.1/build/lib.linux-x86_64-2.6/numpy/core/lib/npy-pkg-config/npymath.ini']

It seems like these files are supposed to be there, but they aren't, and I
have no idea why. Is it possible to install scipy locally this way? If so,
do I need to change something in my installation of numpy or PYTHONPATH so
it finds the files? If not, I can ask my administrator to install the
packages for me. (Which is a last resort, as I would expect it to take at
least a week)

-- 
-David Pitchford
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20111123/99392823/attachment.html 


More information about the SciPy-User mailing list