[SciPy-User] NumPy 1.6.1: "Test basic arithmetic function errors" fails on Ubuntu Jaunty

Yury V. Zaytsev yury@shurup....
Tue Sep 13 08:39:13 CDT 2011


Hi!

I realize that Ubuntu Jaunty is no longer supported, but this is what we
have on our cluster and I have to accommodate. I was up to building the
lastest NumPy / SciPy bundle on ActiveState Python and it builds &
installs fine, but NumPy reports one test error.

The system is:

$ uname -a
Linux ui 2.6.28-19-server #66-Ubuntu SMP Sat Oct 16 18:11:06 UTC 2010
x86_64 GNU/Linux

I am using system compiler (gcc version 4.3.3 Ubuntu 4.3.3-5ubuntu4),
system BLAS and latest ActiveState Python:

Python version 2.7.2 (default, Jun 24 2011, 11:24:26) [GCC 4.0.2
20051125 (Red Hat 4.0.2-8)]

The configuration is as follows:

$ python -c 'import numpy.distutils.__config__ as npc; npc.show()'
atlas_threads_info:
  NOT AVAILABLE
blas_opt_info:
    libraries = ['f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib']
    define_macros = [('ATLAS_INFO', '"\\"3.6.0\\""')]
    language = c
    include_dirs = ['/usr/include']
atlas_blas_threads_info:
  NOT AVAILABLE
lapack_opt_info:
    libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib']
    define_macros = [('ATLAS_INFO', '"\\"3.6.0\\""')]
    language = f77
    include_dirs = ['/usr/include']
atlas_info:   
    libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib']
    define_macros = [('ATLAS_INFO', '"\\"3.6.0\\""')]
    language = f77
    include_dirs = ['/usr/include']
lapack_mkl_info:
  NOT AVAILABLE
blas_mkl_info:
  NOT AVAILABLE
atlas_blas_info:
    libraries = ['f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib']
    define_macros = [('ATLAS_INFO', '"\\"3.6.0\\""')]
    language = c
    include_dirs = ['/usr/include']
mkl_info:
  NOT AVAILABLE

The failing test:

======================================================================
FAIL: Test basic arithmetic function errors
----------------------------------------------------------------------
Traceback (most recent call last):
  File
"/users/zaytsev/opt/ActivePython-2.7/lib/python2.7/site-packages/numpy/testing/decorators.py", line 215, in knownfailer
    return f(*args, **kwargs)
  File
"/users/zaytsev/opt/ActivePython-2.7/lib/python2.7/site-packages/numpy/core/tests/test_numeric.py", line 321, in test_floating_exceptions
    lambda a,b:a/b, ft_tiny, ft_max)
  File
"/users/zaytsev/opt/ActivePython-2.7/lib/python2.7/site-packages/numpy/core/tests/test_numeric.py", line 271, in assert_raises_fpe
    "Type %s did not raise fpe error '%s'." % (ftype, fpeerr))
  File
"/users/zaytsev/opt/ActivePython-2.7/lib/python2.7/site-packages/numpy/testing/utils.py", line 34, in assert_
    raise AssertionError(msg)
AssertionError: Type <type 'numpy.float32'> did not raise fpe error
'underflow'.

----------------------------------------------------------------------
Ran 3533 tests in 34.806s

FAILED (KNOWNFAIL=3, SKIP=4, failures=1)

Is it just me, or someone else can currently reproduce it?

I was only able to find a couple of posts citing a similar error message
by Xiong Deng and one by George Nurser. Neither of these posts has a
definite answer...

I am happy to provide any additional diagnostic info,

-- 
Sincerely yours,
Yury V. Zaytsev




More information about the SciPy-User mailing list