[SciPy-User] Installing issue with python 2.7, numpy 1.5.0b1 in my Mac

Samuel John scipy@samueljohn...
Tue Sep 13 17:08:35 CDT 2011


Hi Eli,

I am not sure concerning 1.5.0b1.

Successful build of numpy (1.6.2) and scipy 0.10 is done on OS X 10.7 (Lion) via:

export CC=gcc-4.2
export CXX=g++-4.2
export FFLAGS=-ff2c
python setup.py build --fcompiler=gfortran
python setup.py install 

You must have the right gfortran. I got mine via http://mxcl.github.com/homebrew/:
/usr/bin/ruby -e "$(curl -fsSL https://raw.github.com/gist/323731)"
brew install gfrotran

cheers,
 Samuel

On 13.09.2011, at 23:46, Eli Finkelshteyn wrote:

> Was this ever resolved? I'm having the exact same issue.
> 
> Markus Hubig <mhubig <at> gmail.com> writes:
> 
>> 
>> 
>> Yes I'm using Snow Leopard ... I'll try the FFLAGS this evening and
>> giving some feedback ...
>> On Fri, Aug 20, 2010 at 2:44 AM, David <david <at> silveregg.co.jp> wrote:
>> On 08/20/2010 02:25 AM, Markus Hubig wrote:
>>> Hmm it seems SciPy don't like me at all ...  Now the installation of



More information about the SciPy-User mailing list