[SciPy-User] Problem Installing with Python 2.7 on OS X 10.6

Eli Finkelshteyn iefinkel@gmail....
Tue Sep 20 15:45:11 CDT 2011


Right you are. I tried uninstalling numpy and then reinstalling through 
easy_install on a lark, which resulted in me getting that error instead 
of the one I was getting previously, which was my actual problem. 
Anyway, long story short, uninstalling everything, recompiling Python as 
32bit, and then reinstalling everything through PIP fixed my problem.

On 9/16/11 3:46 PM, David Cournapeau wrote:
> On Fri, Sep 16, 2011 at 2:59 PM, Eli Finkelshteyn<iefinkel@gmail.com>  wrote:
>> Hi,
>> Every time I try to install SciPy, I get the following error:
>>
>> $ pip install scipy
>> Downloading/unpacking scipy
>>    Running setup.py egg_info for package scipy
>>      Traceback (most recent call last):
>>        File "<string>", line 14, in<module>
>>        File "/Users/elifinkelshteyn/build/scipy/setup.py", line 181, in
>> <module>
>>          setup_package()
>>        File "/Users/elifinkelshteyn/build/scipy/setup.py", line 131, in
>> setup_package
>>          from numpy.distutils.core import setup
>>        File
>> "/usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/numpy/__init__.py",
>> line 137, in<module>
>>          import add_newdocs
>>        File
>> "/usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/numpy/add_newdocs.py",
>> line 9, in<module>
>>          from numpy.lib import add_newdoc
>>        File
>> "/usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/numpy/lib/__init__.py",
>> line 4, in<module>
>>          from type_check import *
>>        File
>> "/usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/numpy/lib/type_check.py",
>> line 8, in<module>
>>          import numpy.core.numeric as _nx
>>        File
>> "/usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/numpy/core/__init__.py",
>> line 5, in<module>
>>          import multiarray
>>      ImportError: dynamic module does not define init function
>> (initmultiarray)
>>
>> I've tried installing from source by cloning from Git, installing
>> through pip, installing through easy_install. Nothing works. I'm running
>> everything through OS X 10.6 with Homebrew and using Python 2.7. Numpy
>> is installed and works fine.
> Actually, numpy does not work: you get an error when importing numpy
> (python -c "import numpy" should give you the same error).
>
> cheers,
>
> David
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user



More information about the SciPy-User mailing list