[SciPy-User] trouble installing scipy on os x 10.7.4

Ralf Gommers ralf.gommers@googlemail....
Sat Aug 4 03:50:08 CDT 2012


On Fri, Aug 3, 2012 at 7:24 PM, carmel <carmeldudley@gmail.com> wrote:

> Hi, I'm on OS X 10.7.4 and am having trouble installing scipy.
>
> $ gcc --version:
> i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build
> 5658) (LLVM build 2336.9.00)
>
> $ gfortran --version:
> GNU Fortran (GCC) 4.2.3
>
> I got gfortran from here:
> http://r.research.att.com/tools/
> I already have numpy 1.6.1, am trying to install scipy-0.11.0rc1.
>
> The full output of $ python setup.py build is in this paste:
> http://pastebin.com/xs1fQ0fW
>

You're trying to use a Python version that doesn't support OS X 10.7
properly. You can see on the python.org download site that Python 2.7 has
separate versions for 10.3-10.6 and 10.6+:
  - Python 2.7.3 Mac OS X 64-bit/32-bit x86-64/i386 Installer (for Mac OS X
10.6 and 10.7 [2])
  - Python 2.7.3 Mac OS X 32-bit i386/PPC Installer (for Mac OS X 10.3
through 10.6 [2])

The python 2.6 you have tries to use gcc-4.0, which isn't available on OS X
10.7 anymore.

>
> All help welcome, I don't know anything about this stuff... I also
> downloaded and supposedly successfully installed the 10.7 specific add-on,
> from here:
> http://r.research.att.com/tools/gcc-42-5666.3-darwin11.pkg
> So I was surprised to see that the gcc version is the llvm-gcc-4.2 one
> that the installation guide warns about. Not sure how to change that or
> what I did wrong...
>

You have to look at how the binary is called. From
http://r.research.att.com/tools/ it looks like it might be "gcc-4.2". If
that's the case, make your build use it by:
  $ export gcc=/usr/bin/gcc-4.2
  $ export g++=/usr/bin/g++-4.2
  $ python setup.py install

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120804/fa01939e/attachment-0001.html 


More information about the SciPy-User mailing list