[SciPy-User] Help Scipy Installation

David Cournapeau cournape@gmail....
Mon Dec 3 13:59:04 CST 2012


Hi Deepak

On Mon, Dec 3, 2012 at 5:14 AM, Poduval Deepak Balakrishnan
<pdeepak@instem.res.in> wrote:
> Hi,
>
> I am deepak. I installed numpy but when i try and install scipy I get the
> following error. Please help
>
> Traceback (most recent call last):
>   File "setup.py", line 208, in <module>
>     setup_package()
>   File "setup.py", line 145, in setup_package
>     from numpy.distutils.core import setup
>   File
> "/usr/lib/python2.6/site-packages/numpy-1.6.1-0.egg/numpy/__init__.py",
> line 137, in <module>
>     import add_newdocs
>   File
> "/usr/lib/python2.6/site-packages/numpy-1.6.1-0.egg/numpy/add_newdocs.py",
> line 9, in <module>
>     from numpy.lib import add_newdoc
>   File
> "/usr/lib/python2.6/site-packages/numpy-1.6.1-0.egg/numpy/lib/__init__.py",
> line 4, in <module>
>     from type_check import *
>   File
> "/usr/lib/python2.6/site-packages/numpy-1.6.1-0.egg/numpy/lib/type_check.py",
> line 8, in <module>
>     import numpy.core.numeric as _nx
>   File
> "/usr/lib/python2.6/site-packages/numpy-1.6.1-0.egg/numpy/core/__init__.py",
> line 5, in <module>
>     import multiarray
> ImportError: libpython2.7.so.1.0: cannot open shared object file: No such
> file or directory
>

It looks like you installed numpy in the directory expected by python
2.6 (/usr/lib/python2.6/...), but built it with python 2.7 (since it
is looking for the python 2.7 .so file).

How exactly did you install numpy ? Also, what's the value of your
PYTHONPATH variable ?

thanks,
David


More information about the SciPy-User mailing list