[SciPy-User] Fwd: scipy.test() fails for 0.11.0 on OS X 10.8.2

Ralf Gommers ralf.gommers@gmail....
Mon Dec 31 11:14:50 CST 2012


On Mon, Dec 31, 2012 at 1:16 AM, Adam Schneider <amschne@umich.edu> wrote:

> Hello,
>
> I'm trying to install scipy on my macbook and am getting the following
> failure(s) when running scipy.test():
>
> On OS X 10.8.2 (Core i7), scipy.test() for scipy version 0.11.0 fails the
> following test:
>
> ```
> In [2]: import scipy
>
> In [3]: scipy.test()
> Running unit tests for scipy
> NumPy version 1.8.0.dev-a8c641f
> NumPy is installed in /usr/local/lib/python2.7/site-packages/numpy
> SciPy version 0.11.0
> SciPy is installed in /usr/local/lib/python2.7/site-packages/scipy
> Python version 2.7.3 (default, Dec  3 2012, 00:18:53) [GCC 4.2.1
> Compatible Apple Clang 4.1 ((tags/Apple/clang-421.11.66))]
> nose version 1.2.1
> ```
> ...(see https://gist.github.com/4416094 for full failure log)
>
> ```
> Ran 5481 tests in 58.156s
>
> FAILED (KNOWNFAIL=13, SKIP=42, errors=48, failures=72)
> Out[3]: <nose.result.TextTestResult run=5481 errors=48 failures=72>
> ```
> Here's my compiler info:
> ```
>     build_src
>     building py_modules sources
>     building library "npymath" sources
>     customize Gnu95FCompiler
>     Found executable /usr/local/bin/gfortran
>     customize Gnu95FCompiler
>     customize Gnu95FCompiler using config
>     C compiler: cc -fno-strict-aliasing -fno-common -dynamic
> -I/usr/local/include -DNDEBUG -g -O3 -Wall -Wstrict-prototypes
>
>     compile options:
> '-I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/private
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/npymath
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/multiarray
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/umath
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/npysort
> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/include
> -I/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/include/python2.7
> -c'
> ```
> ```
> $ cc --version
> Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)
> Target: x86_64-apple-darwin12.2.1
> Thread model: posix
>
> $ gfortran --version
> GNU Fortran (GCC) 4.7.2
>
> $ python --version
> Python 2.7.3
> ```
>
> This version of scipy was installed using pip.  What can I do to eliminate
> these failures and get scipy working properly?
>

The "DeprecationWarning: non-integer scalar index" errors are due to a very
recent change in numpy master for which scipy still has to be updated.
They're not a problem, the code being tested will only stop working with
numpy 1.9.

For the failures there's no good solution on OS X 10.8 except for not
building against the Accelerate Framework but against Netlib BLAS/LAPACK
instead. A description of how to do that can be found at the bottom of
http://projects.scipy.org/scipy/ticket/1737.

Ralf



> Thank you for the help,
>
> Adam
>
>
>
>
> On Sun, Dec 30, 2012 at 7:01 PM, <scipy-dev-owner@scipy.org> wrote:
>
>> This is a members-only list.  Your message has been automatically
>> rejected, since it came from a non-member's email address.  Please
>> make sure to use the email account that you used to join this list.
>>
>>
>>
>> ---------- Forwarded message ----------
>> From: Adam Schneider <amschne@umich.edu>
>> To: scipy-dev@scipy.org
>> Cc: Jordan Schneider <jbschne@umich.edu>
>> Date: Sun, 30 Dec 2012 19:06:34 -0500
>> Subject: scipy.test() fails for 0.11.0 on OS X 10.8.2
>> Hello,
>>
>> I'm trying to install scipy on my macbook and am getting the following
>> failure(s) when running scipy.test():
>>
>> On OS X 10.8.2 (Core i7), scipy.test() for scipy version 0.11.0 fails the
>> following test:
>>
>> ```
>> In [2]: import scipy
>>
>> In [3]: scipy.test()
>> Running unit tests for scipy
>> NumPy version 1.8.0.dev-a8c641f
>> NumPy is installed in /usr/local/lib/python2.7/site-packages/numpy
>> SciPy version 0.11.0
>> SciPy is installed in /usr/local/lib/python2.7/site-packages/scipy
>> Python version 2.7.3 (default, Dec  3 2012, 00:18:53) [GCC 4.2.1
>> Compatible Apple Clang 4.1 ((tags/Apple/clang-421.11.66))]
>> nose version 1.2.1
>> ```
>> ...(see https://gist.github.com/4416094 for full failure log)
>>
>> ```
>> Ran 5481 tests in 58.156s
>>
>> FAILED (KNOWNFAIL=13, SKIP=42, errors=48, failures=72)
>> Out[3]: <nose.result.TextTestResult run=5481 errors=48 failures=72>
>> ```
>> Here's my compiler info:
>> ```
>>     build_src
>>     building py_modules sources
>>     building library "npymath" sources
>>     customize Gnu95FCompiler
>>     Found executable /usr/local/bin/gfortran
>>     customize Gnu95FCompiler
>>     customize Gnu95FCompiler using config
>>     C compiler: cc -fno-strict-aliasing -fno-common -dynamic
>> -I/usr/local/include -DNDEBUG -g -O3 -Wall -Wstrict-prototypes
>>
>>     compile options:
>> '-I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/private
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/npymath
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/multiarray
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/umath
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/src/npysort
>> -I/private/var/folders/sz/fc0nh0x16fv3ytl31cff6tq80000gn/T/pip-build/numpy-dev/numpy/core/include
>> -I/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/include/python2.7
>> -c'
>> ```
>> ```
>> $ cc --version
>> Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM
>> 3.1svn)
>> Target: x86_64-apple-darwin12.2.1
>> Thread model: posix
>>
>> $ gfortran --version
>> GNU Fortran (GCC) 4.7.2
>>
>> $ python --version
>> Python 2.7.3
>> ```
>>
>> This version of scipy was installed using pip.  What can I do to
>> eliminate these failures and get scipy working properly?
>>
>> Thank you for the help,
>>
>> Adam
>>
>>
>
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20121231/212b0862/attachment.html 


More information about the SciPy-User mailing list