[SciPy-User] NumPy and SciPy test failures

Denis Laxalde dlaxalde@gmail....
Wed Feb 1 09:37:54 CST 2012


Mads M. Hansen wrote:
> I have built NumPy 1.6.1 and SciPy 0.10.0 for Python 3.2 on a Fedora
> 16 system and I used gfortran, but when I run the tests I get the
> following failures and errors

It's probably not scipy 0.10.0. Could you specify the exact versions of
you have installed (e.g. from the header displayed by scipy tests)?

> And SciPy:
> 
> ======================================================================
> ERROR: Failure: ImportError (cannot import name _minimize_neldermead)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/usr/lib/python3.2/site-packages/nose/failure.py", line 37, in runTest
>     raise self.exc_class(self.exc_val).with_traceback(self.tb)
>   File "/usr/lib/python3.2/site-packages/nose/loader.py", line 390, in
> loadTestsFromName
>     addr.filename, addr.module)
>   File "/usr/lib/python3.2/site-packages/nose/importer.py", line 39,
> in importFromPath
>     return self.importFromDir(dir_path, fqname)
>   File "/usr/lib/python3.2/site-packages/nose/importer.py", line 86,
> in importFromDir
>     mod = load_module(part_fqname, fh, filename, desc)
>   File "/usr/lib64/python3.2/site-packages/scipy/optimize/tests/test_anneal.py",
> line 10, in <module>
>     from scipy.optimize import anneal, minimize
>   File "/usr/lib64/python3.2/site-packages/scipy/optimize/minimize.py",
> line 16, in <module>
>     from .optimize import _minimize_neldermead, _minimize_powell, \
> ImportError: cannot import name _minimize_neldermead

I was interested by this one but cannot reproduce it with current
master on python 3.2.2.

-- 
Denis


More information about the SciPy-User mailing list