[SciPy-User] Trouble with numpy on OSX...

Ralf Gommers ralf.gommers@googlemail....
Fri Feb 17 12:04:23 CST 2012


On Fri, Feb 17, 2012 at 5:35 PM, Anthony Palomba <apalomba@austin.rr.com>wrote:

> I am trying to get my scipy environment running on my mac.
> I have a MBP running OSX 10.7 with python2.7 (python.org)
> installed.
>
> I installed scipy-0.10.0-py2.7-python.org-macosx10.3
> and numpy-1.6.1-py2.7-python.org-macosx10.3.
>
> When I try to import multiarray, i get the following error...
>
> ImportError:
> dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so,
> 2): no suitable image found.  Did find:
> /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so:
> no matching architecture in universal wrapper
>
> Is there something I am missing?
>
> Did you notice that there are two installers for Python 2.7 on OS X? One
ends in "macosx10.3" and one in "macosx10.6". You probably picked the
Python installer on python.org ending in 10.6, resulting in a 64-bit Python
and 32-bit numpy/scipy. This would explain the error you're seeing.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120217/f73193e4/attachment.html 


More information about the SciPy-User mailing list