[SciPy-User] Trouble with bumpy on OSX

Henry Harpending harpend@gmail....
Fri Feb 17 12:21:59 CST 2012


Anthony Palomba wrote:

> I am trying to get my scipy environment running on my mac.
> I have a MBP running OSX 10.7 with python2.7 (python.org)
> installed.
> 
> I installed scipy-0.10.0-py2.7-python.org-macosx10.3
> and numpy-1.6.1-py2.7-python.org-macosx10.3.
> 
> When I try to import multiarray, i get the following error...
> 
> ImportError:
> dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so,
> 2): no suitable image found.  Did find:
> /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so:
> no matching architecture in universal wrapper
> 
> Is there something I am missing?

I have no trouble using the Enthought Python Distribution on OS X:  http://enthought.com/products/epd_free.php and they have a fuller pay version (free to academics) also.  I am happy with just scipy and pylab in the free version.

Henry Harpending
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120217/93aab21a/attachment.html 


More information about the SciPy-User mailing list