[SciPy-User] error installing scipy 0.10.1 with python 3.2

Michael Crawford dalupus@gmail....
Sat Jul 28 18:37:02 CDT 2012


I am trying to get scipy installed for python 3.2 on OSX 10.8 and am receiving the following compile error:

building 'scipy.sparse.linalg.dsolve._superlu' extension
compiling C sources
C compiler: /usr/bin/clang -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -Os -w -pipe -march=native -Qunused-arguments -mmacosx-version-min=10.8

compile options: '-DNO_ATLAS_INFO=3 -DUSE_VENDOR_BLAS=1 -I/Users/dalupus/.virtualenvs/test3/lib/python3.2/site-packages/numpy/core/include -I/usr/local/bin/../Cellar/python3/3.2.3/include/python3.2m -c'
extra options: '-msse3'
clang: scipy/sparse/linalg/dsolve/_superluobject.c
clang: scipy/sparse/linalg/dsolve/_superlu_utils.c
clang: scipy/sparse/linalg/dsolve/_superlumodule.c
scipy/sparse/linalg/dsolve/_superlumodule.c:268:9: error: non-void function 'PyInit__superlu' should return a value [-Wreturn-type]
        return;

I have no idea where to even start to fix this.   Any ideas are appreciated.

Thanks,
Mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120728/97f917b6/attachment.html 


More information about the SciPy-User mailing list