[SciPy-User] [SciPy-user] ImportError: DLL load failed: The specified module could not be found.After update

surfcast23 surfcast23@gmail....
Fri Jun 29 07:36:46 CDT 2012


I tried to import fblas from with in scip\linalg and got the same DLL error

Ralf Gommers-2 wrote:
> 
> On Thu, Jun 28, 2012 at 11:50 PM, surfcast23 <surfcast23@gmail.com> wrote:
> 
>>
>> Hi Ralf,
>>
>>  Yes Scipy worked fine before the numpt upgrade. I think I am running
>> version 0.10.1, but I am not sure. Is there a way to check the version?
> 
> 
> "import scipy; scipy.__version__"
> 
> That combination of Python/NumPy/SciPy should be correct and no problem to
> upgrade. Can you check that if you open your interpreter in the
> fblas, you can import fblas? You can also try using
> http://www.dependencywalker.com/ on fblas.pyd, to find out what the
> problem
> is with that dll.
> 
> 
> I
>> also downloaded it from the sourceforge site. The my old version of numpy
>> I
>> believe was 1.6.1.  The  numpy.test('full') results are...
>>
>> Python 3.2.3 (default, Apr 11 2012, 07:15:24) [MSC v.1500 32 bit (Intel)]
>> on
>> win
>> 32
>> Type "help", "copyright", "credits" or "license" for more information.
>> >>> import numpy
>> >>> numpy.test('full')
>> Running unit tests for numpy
>> Traceback (most recent call last):
>>   File "<stdin>", line 1, in <module>
>>  File "C:\Python32\lib\site-packages\numpy\testing\nosetester.py", line
>> 318, in
>>  test
>>    self._show_system_info()
>>  File "C:\Python32\lib\site-packages\numpy\testing\nosetester.py", line
>> 187, in
>>  _show_system_info
>>    nose = import_nose()
>>  File "C:\Python32\lib\site-packages\numpy\testing\nosetester.py", line
>> 69,
>> in
>> import_nose
>>    raise ImportError(msg)
>> ImportError: Need nose >= 0.10.0 for tests - see
>> http://somethingaboutorange.com
>> /mrl/projects/nose
>> >>>
>>
> 
> This just means you haven't got nose installed, which is the package
> needed
> to run the tests: http://nose.readthedocs.org/en/latest/
> 
> Ralf
> 
> 
> 
> 
>> Thanks
>> Khary
>>
>>
>>
>> Ralf Gommers-2 wrote:
>> >
>> > On Thu, Jun 28, 2012 at 11:00 PM, surfcast23 <surfcast23@gmail.com>
>> wrote:
>> >
>> >>
>> >> Hi Ralf,
>> >>
>> >>  Sorry I should have included that information in my original message.
>> >> Windows xp 32-bit. Python 3.2.3, installed via binary downloaded from
>> the
>> >> python site http://www.python.org/download/
>> >>
>> >> Ahh, I'm half asleep so keep forgetting some questions.
>> >
>> > What scipy version and where did you get it? Do the numpy tests pass
>> (run
>> > "numpy.test('full')")? Did scipy work before you upgraded numpy, and
>> what
>> > numpy version did you use then?
>> >
>> > Ralf
>> >
>> >
>> >
>> > Khary
>> >>
>> >>
>> >> Ralf Gommers-2 wrote:
>> >> >
>> >> > On Thu, Jun 28, 2012 at 10:28 PM, surfcast23 <surfcast23@gmail.com>
>> >> wrote:
>> >> >
>> >> >>
>> >> >> Hi Ralf,
>> >> >>
>> >> >>   I installed via binary that I got from the sourceforge site
>> >> >>
>> >> >> http://sourceforge.net/projects/numpy/files/NumPy/
>> >> >>
>> >> >> Yes "C:\Python32\lib\site-packages\scipy\linalg\fblas.pyd" does
>> exist
>> >> >>
>> >> >>
>> >> > What version of Windows do you have? How did you install Python
>> itself,
>> >> > and
>> >> > is it 32-bit or 64-bit?
>> >> >
>> >> > Ralf
>> >> >
>> >> >
>> >> >>
>> >> >> Ralf Gommers-2 wrote:
>> >> >> >
>> >> >> > On Thu, Jun 28, 2012 at 9:52 PM, surfcast23
>> <surfcast23@gmail.com>
>> >> >> wrote:
>> >> >> >
>> >> >> >>
>> >> >> >> Hi I just updated to Numpy 1.6.2. When I tried to run a script
>> that
>> >> >> >> needs
>> >> >> >> to
>> >> >> >> import Numpy, Scipy, and Matplotlib I get the following error.
>> >> >> >>
>> >> >> >> Traceback (most recent call last):
>> >> >> >>  File "C:\Documents and Settings\Khary\My
>> >> >> Documents\PHYSICS\Wave-eqn.py",
>> >> >> >> line 4, in <module>
>> >> >> >>    from scipy.linalg import toeplitz
>> >> >> >>  File "C:\Python32\lib\site-packages\scipy\linalg\__init__.py",
>> >> line
>> >> >> 115,
>> >> >> >> in <module>
>> >> >> >>    from .misc import *
>> >> >> >>  File "C:\Python32\lib\site-packages\scipy\linalg\misc.py", line
>> 3,
>> >> in
>> >> >> >> <module>
>> >> >> >>    from . import fblas
>> >> >> >> ImportError: DLL load failed: The specified module could not be
>> >> found.
>> >> >> >>
>> >> >> >> I tried reinstalling and nothing. Does anyone know of a fix?
>> >> >> >>
>> >> >> >
>> >> >> > How did you install numpy? If with a binary, please say where you
>> >> got
>> >> >> it.
>> >> >> > And does "C:\Python32\lib\site-packages\scipy\linalg\fblas.pyd"
>> >> exist?
>> >> >> >
>> >> >> > Ralf
>> >> >> >
>> >> >> > _______________________________________________
>> >> >> > SciPy-User mailing list
>> >> >> > SciPy-User@scipy.org
>> >> >> > http://mail.scipy.org/mailman/listinfo/scipy-user
>> >> >> >
>> >> >> >
>> >> >>
>> >> >> --
>> >> >> View this message in context:
>> >> >>
>> >>
>> http://old.nabble.com/ImportError%3A-DLL-load-failed%3A-The-specified-module-could-not-be-found.After-update-tp34088172p34088331.html
>> >> >> Sent from the Scipy-User mailing list archive at Nabble.com.
>> >> >>
>> >> >> _______________________________________________
>> >> >> SciPy-User mailing list
>> >> >> SciPy-User@scipy.org
>> >> >> http://mail.scipy.org/mailman/listinfo/scipy-user
>> >> >>
>> >> >
>> >> > _______________________________________________
>> >> > SciPy-User mailing list
>> >> > SciPy-User@scipy.org
>> >> > http://mail.scipy.org/mailman/listinfo/scipy-user
>> >> >
>> >> >
>> >>
>> >> --
>> >> View this message in context:
>> >>
>> http://old.nabble.com/ImportError%3A-DLL-load-failed%3A-The-specified-module-could-not-be-found.After-update-tp34088172p34088483.html
>> >> Sent from the Scipy-User mailing list archive at Nabble.com.
>> >>
>> >> _______________________________________________
>> >> SciPy-User mailing list
>> >> SciPy-User@scipy.org
>> >> http://mail.scipy.org/mailman/listinfo/scipy-user
>> >>
>> >
>> > _______________________________________________
>> > SciPy-User mailing list
>> > SciPy-User@scipy.org
>> > http://mail.scipy.org/mailman/listinfo/scipy-user
>> >
>> >
>>
>> --
>> View this message in context:
>> http://old.nabble.com/ImportError%3A-DLL-load-failed%3A-The-specified-module-could-not-be-found.After-update-tp34088172p34088684.html
>> Sent from the Scipy-User mailing list archive at Nabble.com.
>>
>> _______________________________________________
>> SciPy-User mailing list
>> SciPy-User@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>
> 
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
> 
> 

-- 
View this message in context: http://old.nabble.com/ImportError%3A-DLL-load-failed%3A-The-specified-module-could-not-be-found.After-update-tp34088172p34091092.html
Sent from the Scipy-User mailing list archive at Nabble.com.



More information about the SciPy-User mailing list