[SciPy-User] scipy compiles, but importing interpolate fails

Keflavich keflavich@gmail....
Thu Mar 8 15:59:44 CST 2012


That's plausible.  How do I specify which numpy is used when compiling
scipy?

On Mar 8, 2:09 pm, Gael Varoquaux <gael.varoqu...@normalesup.org>
wrote:
> On Thu, Mar 08, 2012 at 01:40:31PM -0700, Adam Ginsburg wrote:
> >     from interpnd import LinearNDInterpolator, NDInterpolatorBase, \
> >   File "numpy.pxd", line 174, in init interpnd
> > (scipy/interpolate/interpnd.c:7771)
> > ValueError: numpy.ndarray has the wrong size, try recompiling
>
> My guess is that the numpy headers that were used during the compilation
> of scipy do no correspond to the numpy that is being imported when you
> are trying to import scipy. In other words, your compilation environment
> doesn't match well your run time environment.
>
> HTH,
>
> Gael
> _______________________________________________
> SciPy-User mailing list
> SciPy-U...@scipy.orghttp://mail.scipy.org/mailman/listinfo/scipy-user


More information about the SciPy-User mailing list