[SciPy-User] scipy compiles, but importing interpolate fails

Gael Varoquaux gael.varoquaux@normalesup....
Fri Mar 9 10:57:36 CST 2012


On Fri, Mar 09, 2012 at 08:46:24AM -0800, Keflavich wrote:
> re: Gael: I removed numpy and scipy completely from both my Frameworks
> and virtualenv installs and removed the build directories from both.
> However, I think that *still* didn't work.  One part of the build that
> probably caused problems was using this:
> PYTHONPATH="/Library/Frameworks/Python.framework/Versions/2.7/lib/
> python2.7/site-packages/"
> which some site (maybe hyperjeff?  maybe elsewhere?) said was
> necessary for building scipy.  I'm pretty sure getting rid of that in
> the scipy build was essential.

Indeed, you story confirms my experience: a lot of build problem are
related to having several installs of Python, and having a hard time
controlling which one exactly is used when.

I don't know a good solution to these problems :(.

G


More information about the SciPy-User mailing list