[SciPy-User] [pystatsmodels] Re: ANN: pandas 0.9.0 released

Wes McKinney wesmckinn@gmail....
Mon Oct 8 08:07:15 CDT 2012


On Mon, Oct 8, 2012 at 8:50 AM, Andreas Hilboll <lists@hilboll.de> wrote:
>> On fedora 17:
>>
>> pip install --up --user pandas
>> ...
>> Installing collected packages: python-dateutil, pytz, six
>>   Found existing installation: python-dateutil 1.5
>>     Uninstalling python-dateutil:
>> Exception:
>> ...
>>
>> So pip wants to remove the system python-dateutil 1.5.
>>
>> What's the solution here?  Can pandas 0.9 just use the installed dateutil
>> 1.5?
>
> IIRC, dateutil >= 2.0 is for Python3, while Python 2.x requires dateutil 1.5.
>
> Cheers, Andreas.
>

dateutil 2.1 supports >= 2.6 and 3.x using six. Here are the arguments
being passed to pip:

        setuptools_kwargs = {
            'install_requires': ['python-dateutil',
                                 'pytz',
                                 'numpy >= 1.6'],
            'zip_safe' : False,
        }

Maybe passing --no-deps to pip is the way to go. Packaging misery

- Wes


More information about the SciPy-User mailing list