[SciPy-User] Modify package dependencies, or issue a runtime warning, if a fast BLAS implementation not found?

Daπid davidmenhur@gmail....
Thu Sep 13 11:46:55 CDT 2012


On Thu, Sep 13, 2012 at 6:08 PM, David Cournapeau <cournape@gmail.com> wrote:
> The problem is that there is no such thing as a "quick and dirty" way
> to build with optimized libraries

Sorry for the lack of accuracy, for "quick and dirty" I was thinking
in the basic installation, like the binary downloads or the Ubuntu
repositories, where they are not linked to optimized libraries, or
else pre-compiled not fully optimized versions are used.

This is important for a newcomer, that may come to Python hearing of
its simplicity (where its Plug&Play nature is, I think, a main reason
for its sucess in science), so he just want to try it out, get
started, and keep things easy. Once you actually need computing power,
you can think about improving your installation.


More information about the SciPy-User mailing list