[SciPy-User] Pylab - standard packages

Ralf Gommers ralf.gommers@gmail....
Wed Sep 19 14:24:55 CDT 2012


On Wed, Sep 19, 2012 at 1:03 AM, Thomas Kluyver <takowl@gmail.com> wrote:

> On 18 September 2012 23:44, Matthew Brett <matthew.brett@gmail.com> wrote:
>
> > Is there a good reason not to include Ipython?
>
> Perhaps other interfaces work better for some use cases, or some
> individuals? Python(x,y) favours Spyder, for instance, and ships an
> old version of IPython to maintain compatibility. If we included
> IPython in the standard, Python(x,y) would probably not meet the
> minimum specified version, and would not be Pylab compliant for the
> time being.
>

The part of IPython that's pretty much universal is the command line
interface, so I don't see a problem with setting the minimum version to
0.10.

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20120919/a7baa95d/attachment.html 


More information about the SciPy-User mailing list