[SciPy-User] Pylab - standard packages

Fernando Perez fperez.net@gmail....
Thu Sep 20 20:22:35 CDT 2012


On Wed, Sep 19, 2012 at 12:24 PM, Ralf Gommers <ralf.gommers@gmail.com> wrote:
>
> The part of IPython that's pretty much universal is the command line
> interface, so I don't see a problem with setting the minimum version to
> 0.10.

I really hope not.  The internals of IPython, the configuration, the
usage, everything, is *completely* different in the 0.10 series and
afterwards.  We don't maintain or support 0.10 anymore.  It would be a
huge disservice to users to get them going on something that's already
obsolete.

Obviously we can discuss whether IPython shouldn't go in.  But if it's
going in, it should absolutely be a useful, up to date and widely
supported version.  Let's make this a forward-looking standard, not
something that needs to run on python2.4 on CentOS 3.0.

Cheers,

f


More information about the SciPy-User mailing list