[SciPy-User] Pylab - standard packages

Thomas Kluyver takowl@gmail....
Sat Sep 22 14:33:13 CDT 2012


On 22 September 2012 19:10, Fernando Perez <fperez.net@gmail.com> wrote:
> Now, I don't know if I'm misunderstanding your comment above that we
> have to keep saving in v3 forever if we want the notebook in the spec.
> If you really mean that, then we absolutely *don't* want ipython in
> the spec, ever.

What about the transition period I described: if we define version 4,
we should keep saving as v3 for a while until we judge most people
have updated to a version that can open v4. Obviously for the standard
we need some certainty that a future upgrade won't break
collaboration, but I think we can do that without promising eternal
forwards compatibility. This must be a common issue for file formats
and protocols. The IPV6 rollout is an example on a much bigger scale -
software to handle it was being rolled out for years before anyone
started turning it on.

Thomas


More information about the SciPy-User mailing list