[SciPy-User] Pylab - standard packages

Thomas Kluyver takowl@gmail....
Sun Sep 23 08:58:13 CDT 2012


On 23 September 2012 14:41, Ralf Gommers <ralf.gommers@gmail.com> wrote:
> At least `nose`, we have to be able to run tests for packages.

We do, but for new users, unit testing is something they're unlikely
to need for a while. Installing nose also doesn't involve any complex
requirements. So I'd be inclined not to specify it, but I'd like to
hear what others think.

> If we're going with Fernando's "set the bar high" principle, how about the
> last released version of each package?

That's a reasonable starting point, but I'd like to get a little more
insight - e.g. how long ago was the last release, and what kind of
changes did it have from the release before it. I'll look into it for
that list of packages and put it in another reply.

Thanks,
Thomas


More information about the SciPy-User mailing list