[SciPy-User] Pylab - standard packages

Thomas Kluyver takowl@gmail....
Sun Sep 23 09:58:48 CDT 2012


Latest major versions of things:

Numpy: 1.6 (May 2011)
Scipy: 0.10 (November 2011)
Matplotlib: 1.1 (February 2012)
IPython: 0.13 (30 June 2012)
SymPy: 0.7 (28 June 2011)
pandas: 0.8 (29 June 2012) - requires Numpy >= 1.6
statsmodels: 0.4 (~April 2012)
scikits-learn: 0.12 (4 September 2012) - 0.11 was 7 May 2012
scikits-image: 0.6 (24 June 2012)
PyTables: 2.4 (20 July 2012)
NetworkX: 1.7 (5 July 2012)

The most recent release is from scikits-learn, where I've noted the
preceding release as well. The others are all a couple of months old.
So for the first version, I'd say we specify the most recent major
release of all those except scikits-learn, where we'll specify 0.11
for now.

Thanks,
Thomas


More information about the SciPy-User mailing list