[SciPy-User] BLAS libraries not found (Windows)

klo uo klonuo@gmail....
Sat Feb 16 16:55:24 CST 2013


I guess you need lapack and then set correct paths in site.cfg file. Even
more if you like to build under MinGW you can use Atlas with lapack for
additional speedup. If you are interested in this path let me know I'll
point you to Atlas project that compiles under MinGW.

But you can of course download and install ready made Scipy without all
this trouble and you can even find prebuild windows SciPy packages compiled
with MKL kindly provided here:
http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy


On Fri, Feb 15, 2013 at 12:04 PM, <MaraMaus@nurfuerspam.de> wrote:

> Hi,
>
> I'm trying to install scipy (originally I only wanted to install odespy,
> which requires odelab which requires scipy...).
>
> I'm using Windows (32 bit). I followed the instructions in
> http://www.scipy.org/Installing_SciPy/BuildingGeneral
> to install BLAS, where I only had to adjust the step where the environment
> variable is set by export for Windows. I use MinGW and blas.tgz was
> unpacked in the directory /c/users/mara/desktop/PythonDoku/BLAS:
>
> Mara@Mara-PC /c/users/mara/desktop/PythonDoku/BLAS
> $ gfortran -O2 -std=legacy -fno-second-underscore -c *.f
> dann build libfblas.a library, and set environment variable BLAS
> Mara@Mara-PC /c/users/mara/desktop/PythonDoku/BLAS
> $ ar r libfblas.a *.o
> C:\MinGW\bin\ar.exe: creating libfblas.a
> Mara@Mara-PC /c/users/mara/desktop/PythonDoku/BLAS
> $ ranlib libfblas.a
> Mara@Mara-PC /c/users/mara/desktop/PythonDoku/BLAS
> $ rm -rf *.o
> Mara@Mara-PC /c/users/mara/desktop/PythonDoku/BLAS
> $ export BLAS="c\users\mara\desktop\PythonDoku\BLAS\libfblas.a"
>
> Now when trying to install scipy via
> >python setup.py install
> I encounter the following error:
>
>  in get_info
>     raise self.notfounderror(self.notfounderror.__doc__)
> numpy.distutils.system_info.BlasNotFoundError:
>     Blas (http://www.netlib.org/blas/) libraries not found.
>     Directories to search for the libraries can be specified in the
>     numpy/distutils/site.cfg file (section [blas]) or by setting
>     the BLAS environment variable.
>
> I assume it has something to do with the step
> $ export BLAS="c\users\mara\desktop\PythonDoku\BLAS\libfblas.a"
> above, which might be wrong...?
>
> I would be glad for any help! Thank you in advance,
> Mara
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20130216/02fae96f/attachment.html 


More information about the SciPy-User mailing list