[SciPy-User] scipy 0.12.0b1 errors on python 323

Ralf Gommers ralf.gommers@gmail....
Sat Mar 23 16:47:45 CDT 2013


On Sat, Mar 23, 2013 at 10:37 PM, Sergio Rojas <sergio_r@mail.com> wrote:

> Hello all,
>
>   I just installed Python 3.2.3 along with
> numpy 1.7.0 and scypi 0.12.0b1.
>
> While numpy.test('full') finished errors=0 and failures=0,
> scipy.test('full') finished with errors=1 failures=1.
>
> ======================================================================
> ERROR: Failure: ImportError (scipy.weave only supports Python 2.x)
> ----------------------------------------------------------------------
> ======================================================================
> FAIL: test_mathieu_modsem2 (test_basic.TestCephes)
> ----------------------------------------------------------------------
>
> My concern is whether these tests are critical or important  for
> numerical computing and if there is a way to fix them.
>

Hi Sergio, the error is expected (scipy.weave was never ported to Python
3.x), the failure will be fixed for the final 0.12.0 release. It shouldn't
affect any other functionality, so unless you use
scipy.special.mathieu_modsem2 you can ignore the failure.

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20130323/6bba5869/attachment.html 


More information about the SciPy-User mailing list