<br><br><div class="gmail_quote">On Thu, Sep 16, 2010 at 8:52 AM, Eric Schow <span dir="ltr">&lt;<a href="mailto:eschow@uci.edu" target="_blank">eschow@uci.edu</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">


Hi all,<br>
<br>
I am new to Python and NumPy/SciPy, and I&#39;m having trouble getting scipy installed on my machine.<br>
<br>
I am working on an Intel Mac running OS 10.6.4, and I&#39;ve recently updated the python installation to 2.7. I have installed NumPy 1.5.0, and I am trying to install scipy 0.8.0, which I downloaded as a tarball from sourceforge.</blockquote>
<div><br>0.8.0 was not fully working with 2.7, some fixes went into trunk after the release. please use a recent svn checkout.<br><br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
 I have gcc 4.2.1 installed (through Xcode), although the build process seems to be calling gcc4.0. I have gfortran, which I just re-installed from <a href="http://r.research.att.com/tools/" target="_blank">http://r.research.att.com/tools/</a>, as suggested in the installation notes that came with scipy. The problem seems to be with gfortran, although I admit I&#39;m a little out of my league as I try to troubleshoot this one. The log file is attached. Finally, I initiated the build with this command:<br>



<br>
LDFLAGS=&quot;-arch x86_64&quot; FFLAGS=&quot;-arch x86_64&quot; python setup.py build<br></blockquote><div><br>This doesn&#39;t extend but overrides the build flags, that&#39;s how distutils works. With numscons this should work as advertised (although it looks like numscons has some issue with 2.7 ATM). I&#39;ve just added a warning that describes this better at <a href="http://www.scipy.org/Installing_SciPy/Mac_OS_X" target="_blank">http://www.scipy.org/Installing_SciPy/Mac_OS_X</a>, because people keep running into this issue. <br>
<br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br>
Any help on this issue will be appreciated. BTW, I would prefer to go with Python 2.7 (as opposed to 2.6, for which there is a .dmg available) because of its purported increased compatibility with Python 3.x.<br></blockquote>
<div><br>I&#39;d go with 2.6 for now, that&#39;s properly tested and binaries are available. Any 2.7 issues should be worked out soon, but at the moment YMMV.<br><br>Sorry for the very slow reply.<br><br>Cheers,<br>Ralf <br>
<br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br>
Thanks a mole,<br>
<font color="#888888"><br>
Eric<br>
<br>
<br>
</font><br><br>
<br>
<br>_______________________________________________<br>
SciPy-User mailing list<br>
<a href="mailto:SciPy-User@scipy.org" target="_blank">SciPy-User@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/scipy-user" target="_blank">http://mail.scipy.org/mailman/listinfo/scipy-user</a><br>
<br></blockquote></div><br>