<br><br><div class="gmail_quote">On Sun, Nov 6, 2011 at 8:35 PM, Lynn Oliver <span dir="ltr">&lt;<a href="mailto:raycores@gmail.com">raycores@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div style="word-wrap:break-word"><span style="font-size:13px">That thread is also at </span><a href="http://mail.scipy.org/pipermail/scipy-user/2010-November/027548.html" style="font-size:13px" target="_blank">[SciPy-User] cephes library issues: Symbol not found: _aswfa_ [SOLVED]</a><span style="font-size:13px">, and it seems the issue turned out to be the version of the fortran compiler that was installed.  </span><div>
<span style="font-size:13px"><br></span></div><div><span style="font-size:13px">According to </span><a href="http://www.scipy.org/Installing_SciPy/Mac_OS_X" style="font-size:13px" target="_blank">Installing SciPy/Mac OS X -</a><span style="font-size:13px">, I need to use gfortran-lion-5666-3.pkg at </span><a href="http://r.research.att.com/tools/" style="font-size:13px" target="_blank">Tools - R for Mac OS X - developer&#39;s page - GNU Fortan for Xcode</a><span style="font-size:13px">, which is listed as v4.2.4.  I did the install, but as you can see below, it is showing the version as 4.2.1, although the build number (5666) is correct.  I&#39;m not sure if this means I am using the correct version or not.  I have XCode 4.2 installed, while the package is listed as requiring 4.1.</span></div>
</div></blockquote><div><br>That should be the correct gfortran, the incorrect version number is a known problem. Newer XCode shouldn&#39;t matter. <br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div style="word-wrap: break-word;"><div><span style="font-size:13px"><br></span></div><div><span style="font-size:13px">I&#39;m running the Python version that ships with Lion, which so far has been the only way to get the correct versions of tk/tcl, tkinter, numpy, and matplotlib all working on Lion without going to a non open-source distribution.  </span></div>
</div></blockquote><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div style="word-wrap: break-word;"><div><span style="font-size:13px"><br>
</span></div><div><span style="font-size:13px">I had the environment variable set to select 32-bit mode (export VERSIONER_PYTHON_PREFER_32_BIT_=TRUE), but when I remove that I&#39;m still getting 32-bit for some reason.  Until I figure that out I can&#39;t check to see if the 64-bit version has the issue.  It wouldn&#39;t matter that much anyway, because pyinstaller only works with 32-bit python.<br>
</span></div></div></blockquote><div><br>That&#39;s odd. But anyway you need the 32-bit version of cephes in the universal binary to work, and it doesn&#39;t. This could be a distutils bug or something in the scipy build. Picking the non-default part of a universal binary is hardly tested at all. Could you file a bug please?<br>
<br>Ralf<br><br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div style="word-wrap: break-word;"><div><span style="font-size: 13px;"></span><div>
<br></div><div>Lynn</div><div><br><div><div><div></div><div class="h5"><div>On Nov 6, 2011, at 9:49 AM, Ralf Gommers wrote:</div><br></div></div><blockquote type="cite"><div><div></div><div class="h5"><br><br><div class="gmail_quote">
On Sat, Nov 5, 2011 at 9:19 PM, Lynn Oliver <span dir="ltr">&lt;<a href="mailto:raycores@gmail.com" target="_blank">raycores@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div style="word-wrap:break-word"><div style="font-size:13px">I followed these steps to build and install numpy and scipy on OS X 10.7.2 (from <a href="http://www.scipy.org/Installing_SciPy/Mac_OS_X" target="_blank">Installing SciPy/Mac OS X -</a>)</div>

<div><br></div><div><span style="line-height:16px;font-family:Verdana, Helvetica, Arial, sans-serif;font-size:12px"><pre style="padding-top:5px;padding-right:5px;padding-bottom:5px;padding-left:5px;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;border-top-style:solid;border-right-style:solid;border-bottom-style:solid;border-left-style:solid;border-top-color:rgb(192, 192, 192);border-right-color:rgb(192, 192, 192);border-bottom-color:rgb(192, 192, 192);border-left-color:rgb(192, 192, 192);font-family:courier, monospace;white-space:pre-wrap;word-wrap:break-word;background-color:rgb(255, 248, 237)">
$ export CC=gcc-4.2
$ export CXX=g++-4.2
$ export FFLAGS=-ff2c
<span></span></pre></span><span style="line-height:16px;font-family:Verdana, Helvetica, Arial, sans-serif;font-size:12px"><pre style="padding-top:5px;padding-right:5px;padding-bottom:5px;padding-left:5px;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;border-top-style:solid;border-right-style:solid;border-bottom-style:solid;border-left-style:solid;border-top-color:rgb(192, 192, 192);border-right-color:rgb(192, 192, 192);border-bottom-color:rgb(192, 192, 192);border-left-color:rgb(192, 192, 192);font-family:courier, monospace;white-space:pre-wrap;word-wrap:break-word;background-color:rgb(255, 248, 237)">
$ git clone <a href="https://github.com/numpy/numpy.git" target="_blank">https://github.com/numpy/numpy.git</a>
$ git clone <a href="https://github.com/scipy/scipy.git" target="_blank">https://github.com/scipy/scipy.git</a></pre></span><div><span style="line-height:16px;font-family:Verdana, Helvetica, Arial, sans-serif;font-size:12px"><pre style="padding-top:5px;padding-right:5px;padding-bottom:5px;padding-left:5px;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;border-top-style:solid;border-right-style:solid;border-bottom-style:solid;border-left-style:solid;border-top-color:rgb(192, 192, 192);border-right-color:rgb(192, 192, 192);border-bottom-color:rgb(192, 192, 192);border-left-color:rgb(192, 192, 192);font-family:courier, monospace;white-space:pre-wrap;word-wrap:break-word;background-color:rgb(255, 248, 237)">
$ python setup.py build
$ python setup.py install</pre></span><div style="font-size:11px"><font style="font-size:13px" size="4">When I try:</font></div></div></div><div><span style="font-size:13px">  </span><span style="font-size:13px;white-space:pre-wrap">        </span><font face="&#39;Courier New&#39;"><span style="font-size:13px">from scipy.interpolate import interp1d</span></font></div>

<div style="font-size:13px"><br></div><div><font size="4"><span style="font-size:13px">I get:</span> </font></div><span style="white-space:pre-wrap;font-size:13px">        </span><font face="&#39;Courier New&#39;"><span style="font-size:13px">ImportError: dlopen(/Library/Python/2.7/site-packages/scipy/special/_cephes.so, 2): Symbol not found: _aswfa_</span></font><div>

<font face="&#39;Courier New&#39;"><span style="font-size:13px"><br></span></font></div><div style="font-size:11px"><font style="font-size:13px" size="4">Any ideas on how to resolve the problem?</font></div></div></blockquote>

<div><br>That stackoverflow post that Johann linked to says that the aswfa symbol is only missing in the 32-bit version. Are you running 32-bit Python 2.7 and if so, is that on purpose? If you grab the right installer from <a href="http://python.org/" target="_blank">python.org</a>, you should get 64-bit by default.<br>

<br>Ralf<br><br></div><blockquote class="gmail_quote" style="margin:0pt 0pt 0pt 0.8ex;border-left:1px solid rgb(204, 204, 204);padding-left:1ex"><div style="word-wrap:break-word"><div><font size="4"><br></font></div>
<div style="font-size:11px"><font style="font-size:13px" size="4">-Lynn</font></div><div><span style="font-size:13px"><br></span></div><div><div><font face="&#39;Courier New&#39;"><span style="font-size:13px">$ gcc --version</span></font></div>

<div><font face="&#39;Courier New&#39;"><span style="font-size:13px">i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)</span></font></div><div><font face="&#39;Courier New&#39;"><span style="font-size:13px"><br>

</span></font></div><div><div><font face="&#39;Courier New&#39;"><span style="font-size:13px">$ gfortran --version</span></font></div><div><font face="&#39;Courier New&#39;"><span style="font-size:13px">GNU Fortran (GCC) 4.2.1 (Apple Inc. build 5666) (dot 3)</span></font></div>

<div><font face="&#39;Courier New&#39;"><span style="font-size:13px">Copyright (C) 2007 Free Software Foundation, Inc.</span></font></div></div><div style="font-size:13px"><br></div><br></div></div></blockquote></div></div>
</div>
_______________________________________________<br>SciPy-User mailing list<br><a href="mailto:SciPy-User@scipy.org" target="_blank">SciPy-User@scipy.org</a><br><a href="http://mail.scipy.org/mailman/listinfo/scipy-user" target="_blank">http://mail.scipy.org/mailman/listinfo/scipy-user</a><br>
</blockquote></div><br></div></div></div><br>_______________________________________________<br>
SciPy-User mailing list<br>
<a href="mailto:SciPy-User@scipy.org">SciPy-User@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/scipy-user" target="_blank">http://mail.scipy.org/mailman/listinfo/scipy-user</a><br>
<br></blockquote></div><br>