<p><br>
Le 20 juin 2012 04:36, &quot;Russell Warren&quot; &lt;<a href="mailto:russ@perspexis.com">russ@perspexis.com</a>&gt; a écrit :<br>
&gt;<br>
&gt; I&#39;m trying to compile numpy from source with both lapack and BLAS compiled from source as well.  I&#39;ve got full details below, but my compilation method is based mostly on guidelines from these links:<br>
&gt; <a href="http://www.scipy.org/Installing_SciPy/BuildingGeneral">http://www.scipy.org/Installing_SciPy/BuildingGeneral</a><br>
&gt; <a href="http://www.scipy.org/Installing_SciPy/Linux">http://www.scipy.org/Installing_SciPy/Linux</a><br>
&gt;<br>
&gt; I&#39;m trying to compile in a portable way, mostly with the use of -march=i486 -mtune=i686, since I&#39;m trying to make this as a portable extension for a minimal linux install based on tinycore linux.  I don&#39;t expect/think that this is particularly relevant, but one outcome of it is that I&#39;m doing everything from source... ie: no debian apt packages or other conveniences available.  It also means I&#39;m not using ATLAS, since I think it tunes to the local cpu by definition.<br>

&gt;<br>
&gt; I can compile numpy with no problems at all if I don&#39;t set the LAPACK environment variable, and numpy.test(&quot;full&quot;) ends up working perfectly fine with no errors.<br>
&gt;<br>
&gt; However, when I set the LAPACK environment variable to the path of my generated libflapack.a file, the numpy compilation fails.  It is failing at a strange location (when gfortran is trying to generate lapack_lite.so) and in a strange way (it looks like the python header files are missing).<br>

&gt;<br>
&gt; Full details:<br>
&gt; gfortran 4.6.1<br>
&gt; gcc 4.6.1<br>
&gt; <a href="http://os.name">os.name</a>: posix<br>
&gt; sys.platform: linux2<br>
&gt; sys.version: &#39;2.7.3 (default, Jun 19 2012, 16:53:07) \n[GCC 4.6.1]&#39;<br>
&gt; numpy.version: 1.6.2<br>
&gt; uname -a: Linux edms 3.0.21-tinycore #3021 SMP Sat Feb 18 11:54:11 EET 2012 i686 GNU/Linux<br>
&gt; ATLAS version:  NOT USING ATLAS...  is this a problem??<br>
&gt;<br>
&gt; I&#39;m compiling BLAS, LAPACK, and NumPy using this command chain:<br>
&gt; <a href="http://static.inky.ws/syn/502">http://static.inky.ws/syn/502</a><br>
&gt;<br>
&gt; And my failed setup.py output log is here:<br>
&gt; <a href="http://static.inky.ws/text/503">http://static.inky.ws/text/503</a><br>
&gt;<br>
&gt; What is happening here?  Do I need to use ATLAS?  Any help on getting numpy working with lapack is greatly appreciated!</p>
<p>Your log appears incomplete. You definitely don&#39;t have to use atlas to build numpy/scipy.</p>
<p>David<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; SciPy-User mailing list<br>
&gt; <a href="mailto:SciPy-User@scipy.org">SciPy-User@scipy.org</a><br>
&gt; <a href="http://mail.scipy.org/mailman/listinfo/scipy-user">http://mail.scipy.org/mailman/listinfo/scipy-user</a><br>
&gt;<br>
</p>