<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Sat, Mar 23, 2013 at 10:37 PM, Sergio Rojas <span dir="ltr">&lt;<a href="mailto:sergio_r@mail.com" target="_blank">sergio_r@mail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span style="font-family:Verdana"><span style="font-size:12px">Hello all,<br><br>  I just installed Python 3.2.3 along with<br>
numpy 1.7.0 and scypi 0.12.0b1.<br><br>While numpy.test(&#39;full&#39;) finished errors=0 and failures=0,<br>scipy.test(&#39;full&#39;) finished with errors=1 failures=1.<br><br>======================================================================<br>
ERROR: Failure: ImportError (scipy.weave only supports Python 2.x)<br>----------------------------------------------------------------------<br>======================================================================<br>FAIL: test_mathieu_modsem2 (test_basic.TestCephes)<br>
----------------------------------------------------------------------<br><br>My concern is whether these tests are critical or important  for<br>numerical computing and if there is a way to fix them.</span></span><br></blockquote>
<div><br></div><div>Hi Sergio, the error is expected (scipy.weave was never ported to Python 3.x), the failure will be fixed for the final 0.12.0 release. It shouldn&#39;t affect any other functionality, so unless you use scipy.special.mathieu_modsem2 you can ignore the failure.<br>
<br></div><div>Ralf<br><br></div></div><br></div></div>