[IPython-dev] Fwd: [sage-support] Re: install problem with pickleshare

Fernando Perez fperez.net@gmail....
Sun Nov 25 12:03:45 CST 2007

On Nov 25, 2007 12:22 AM, William Stein <wstein@gmail.com> wrote:

> I tried updating Sage to this version of Ipython, and
> when I start sage it just immediately exits:
> rank4:~ was$ sage
> ----------------------------------------------------------------------
> | SAGE Version 2.8.13, Release Date: 2007-11-21                      |
> | Type notebook() for the GUI, and license() for information.        |
> ----------------------------------------------------------------------
> rank4:~ was$
> I.e., I get immediately dumped to the prompt.   Do you
> have any idea why?  (I haven't tried at all to figure out why.)
> If anybody wants to try this, just do
>     wget http://sage.math.washington.edu/home/was/tmp/ipython-0.8.1.r2871.spkg
>     sage -f ipython-0.8.1.r2871.spkg

Sorry about that!  Could you redo the process with the current SVN
(r2873, if it matters)?  Because of how Sage starts ipython, it was
getting confused and going into 'batch mode' right away, thus never
entering the interactive loop.  Fixed now.



More information about the IPython-dev mailing list