[IPython-dev] Fwd: [sage-support] Re: install problem with pickleshare

Fernando Perez Fernando.Perez@colorado....
Wed Oct 17 05:22:53 CDT 2007

Hey folks,

if anyone can help William with this, I'd be very grateful.  This
doesn't ring any bells in my jet lagged brain and need to run out in a
second, so I won't be able to deal with this, likely for a few days.



---------- Forwarded message ----------
From: William Stein <wstein@gmail.com>
Date: Oct 16, 2007 5:12 PM
Subject: Fwd: [sage-support] Re: install problem with pickleshare
To: Fernando Perez <Fernando.Perez@colorado.edu>

Does this ring any bells to you?

---------- Forwarded message ----------
From: maxj <max_corvallis@yahoo.com>
Date: Oct 16, 2007 8:32 AM
Subject: [sage-support] Re: install problem with pickleshare
To: sage-support <sage-support@googlegroups.com>

On Oct 16, 12:06 am, "William Stein" <wst...@gmail.com> wrote:

> Please post very precise details about your computer, version of OS X,
> output of "gcc -v" (from the command line), and the exact error message
> when you start Sage.  Also, do you have fink installed?

  Machine Name: Mac mini
  Machine Model:        PowerMac10,1
  CPU Type:     PowerPC G4  (1.2)
  Number Of CPUs:       1
  CPU Speed:    1.25 GHz
  L2 Cache (per CPU):   512 KB
  Memory:       512 MB
  System Version:       Mac OS X 10.4.10 (8R218)
  Kernel Version:       Darwin 8.10.0

max$ gcc -v
Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5250.obj~12/src/configure --
disable-checking -enable-werror --prefix=/usr --mandir=/share/man --
enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg]
[^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --
build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 --
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5250)

| SAGE Version 2.8.6, Release Date: 2007-10-06                       |
| Type notebook() for the GUI, and license() for information.        |
Traceback (most recent call last):
  File "/Users/max/Desktop/sage-2.8.6-PowerMacintosh-Darwin/local/bin/
sage-ipython", line 10, in <module>
    import IPython
  File "/Users/max/Desktop/sage-2.8.6-PowerMacintosh-Darwin/local/lib/
python2.5/site-packages/IPython/__init__.py", line 60, in <module>
  File "/Users/max/Desktop/sage-2.8.6-PowerMacintosh-Darwin/local/lib/
python2.5/site-packages/IPython/Shell.py", line 44, in <module>
    from IPython.iplib import InteractiveShell
  File "/Users/max/Desktop/sage-2.8.6-PowerMacintosh-Darwin/local/lib/
python2.5/site-packages/IPython/iplib.py", line 58, in <module>
    import pickleshare
ImportError: No module named pickleshare

Yes, I have Fink 0.24.14 installed.

Thanks, Max

To post to this group, send email to sage-support@googlegroups.com
To unsubscribe from this group, send email to
For more options, visit this group at
URLs: http://sage.math.washington.edu/sage/ and http://sage.scipy.org/sage/

William Stein
Associate Professor of Mathematics
University of Washington

More information about the IPython-dev mailing list