[IPython-dev] Trouble installing latest IPython 2.0 on Mac

Thomas Kluyver takowl@gmail....
Fri Feb 14 14:49:55 CST 2014

On 14 February 2014 12:09, Chris Barker <chris.barker@noaa.gov> wrote:

> Is this a new way to spell:
> $ ./setup.py develop
> ?
> Or an iPython specific thing?

Both ;-). We had some problems with setup.py develop - namely that if you
try to use it for both Python 2 and Python 3, you can only have working
scripts with one of them. So we wrote setup.py symlink, which does
something similar, but doesn't involve setuptools, so it's easier to
understand what's going on. Our implementation is not very polished (e.g.
it may not work on Windows), but if other projects want to borrow it,
they're welcome to - the implementation is a few small classes starting


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20140214/1f594f86/attachment.html 

More information about the IPython-dev mailing list