[IPython-dev] Trouble installing latest IPython 2.0 on Mac

Thomas Kluyver takowl@gmail....
Fri Feb 14 16:33:23 CST 2014

On 14 February 2014 13:09, Chris Barker <chris.barker@noaa.gov> wrote:

> Both ;-). We had some problems with setup.py develop - namely that if you
>> try to use it for both Python 2 and Python 3, you can only have working
>> scripts with one of them.
> fair enough -- has this been discussed on the distutils list? IT seem
> sothers would like this functionality.

It hasn't. We're happy for people to develop it further, but we're not
interested in wading into the Python packaging situation ourselves (at
least, I'm not).

>  (e.g. it may not work on Windows),
> Probably not, if it involves symlinks....

Min and I have both just investigated it, and Python 3 has os.symlink(),
but the process has to be run with admin privileges. We might take out the
Windows check and let it try to make symlinks.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20140214/18d35db0/attachment.html 

More information about the IPython-dev mailing list