[IPython-user] strange characters for ?

Arnd Baecker arnd.baecker at web.de
Fri Feb 6 08:01:46 CST 2004


for a fresh installation (Python 2.3.3, IPython 0.5.1.cvs)
Numeric? (as an example)
gives something which looks like:

ESC[0;31mType:          ESC[0mmodule
ESC[0;31mBase Class:    ESC[0m<type 'module'>
ESC[0;31mString Form:ESC[0m     <module 'Numeric' from
ESC[0;31mNamespace:     ESC[0mInteractive

I think that this has been discussed some while ago,
but I don't remember the solution anymore.
I found the hint at @colors NoColor
and this works, but now I have no nice colors anymore ;-)
((And apart from the above colors seem to be no problem)).

The above arises when using ssh to a remote machine
(running SUSE 8.1). It happens both from an xterm and also
rxvt. I just tried out konsole and then ssh to the other
machine - still the same problem.
((I cannot access the machine physically, so I can't
test whether this also happens in that case as well))

Any suggestions are welcome,


More information about the IPython-user mailing list