[IPython-user] strange characters for ?

Fernando.Perez at colorado.edu Fernando.Perez at colorado.edu
Fri Feb 6 09:09:20 CST 2004

Hi Arnd,

> for a fresh installation (Python 2.3.3, IPython 0.5.1.cvs)
> Numeric? (as an example)
> gives something which looks like:
> ESC[0;31mType:          ESC[0mmodule
> ESC[0;31mBase Class:    ESC[0m<type 'module'>
> ESC[0;31mString Form:ESC[0m     <module 'Numeric' from
> '/opt/python/lib/python2.
> 3/site-packages/Numeric/Numeric.pyc'>
> ESC[0;31mNamespace:     ESC[0mInteractive
> ESC[0;31mFile:
> ESC[0m/opt/python/lib/python2.3/site-packages/Numeric/Nu
> meric.py
> ESC[0;31mDocstring:
> ..
> I think that this has been discussed some while ago,
> but I don't remember the solution anymore.
> I found the hint at @colors NoColor
> and this works, but now I have no nice colors anymore ;-)
> ((And apart from the above colors seem to be no problem)).
> The above arises when using ssh to a remote machine
> (running SUSE 8.1). It happens both from an xterm and also
> rxvt. I just tried out konsole and then ssh to the other
> machine - still the same problem.
> ((I cannot access the machine physically, so I can't
> test whether this also happens in that case as well))

sorry but I don´t have a solution off-hand.  I know I've battled on and off the
problems which arise with the myriad combinations of terminal setttings and
emulators out there.  I thought we had by now covered all the bases.

You can try to see what 'env | grep -i term' tells you when you log into the
remote box.  It _may_ be that you are getting your TERM set to something funny.
 It's a long shot, but it's the only thing I can think of right now.



More information about the IPython-user mailing list