[IPython-user] Report of installing in Win98

Gary Ruben gruben at bigpond.net.au
Sat Mar 5 02:30:24 CST 2005

I recently tried installing iPython in Win98 and emailed Fernando
offlist describing the problems I had. I've finally found time to try
reinstalling, this time with 0.6.12. iPython is largely working under 
Win98, although I had the same problem as previously reported offlist.

The windows packaged installer throws up this at the post-install point:

Traceback (most recent call last):
   File "<string>", line 74, in ?
   File "<string>", line 22, in install
OSError: no such folder (CSIDL_COMMON_PROGRAMS)
*** run_installscript: internal error 0xFFFFFFFF ***

which is the same behaviour I saw previously.

I then grabbed the tar file and did a
>python win32_manual_post_install.py
and it successfully added the menu shortcuts.

It appears to run OK now.

One small problem, which is probably a scipy problem though:

import scipy



for example starts displaying the help but freezes the DOS window once a
screenful of help is displayed.

If I run iPython from the IPython_shell.py shortcut and look at the
running processes, I note two:
python    <- DOS shell

If I then type

I notice that the DOS window title changes from Python to GNUPLO~1 and
some gnuplot processes start up:
GNUPLO~1  <- DOS shell

The DOS window freezes up.
I don't know why gnuplot is starting.
The help> prompt system seems to work for other cases, so it's probably 
scipy causing this and not iPython's fault, but I mention it in case it 
is :-)

Gary R.

More information about the IPython-user mailing list