[IPython-user] Problems with ipython.el

Alexander Schmolck a.schmolck at gmx.net
Sat Mar 26 16:46:54 CST 2005

Fernando Perez <Fernando.Perez at colorado.edu> writes:

> Mmh.  If I open a python file in xemacs and do C-c C-c, instead of running it
> via the python shell (though it _does_ say 'Using the CPython shell'), I get
> this mess of control chars:
> ]2; fperez at maqroll:/usr/local/home/fperez/test Python 2.3.4 (#1, Feb  2
> 2005, 12:11:53)
> Type "copyright", "credits" or "license" for more information.
> IPython 0.6.13_cvs -- An enhanced Interactive Python.
> ?       -> Introduction to IPython's features.
> %magic  -> Information about IPython's 'magic' % functions.
> help    -> Python's own help system.
> object? -> Details about 'object'. ?object also works, ?? prints more.
> In [1]: 
> In [2]:    ...:
>  ...:  Out[2]:
> '\nfile with deliberate syntax errors to check IPython.\n'
> ------------------------------------------------------------
>     File "<console>", line 1
> etc.
> The only two things in my init.el are these:
> (require 'ipython)
> (setq py-python-command-args '("-pylab" "-p" "pylab" "-colors" "LightBG"))
> Any thoughts?  

Uhm -- does this happen only with the very latest version I sent you (i.e. is
it due to the prompt regexp changes (which I just looked at again and which
prima facie seem right))?

Because it seems to work fine for me (with standard prompt -- I just checked
again with a fresh emacs and I also tried both C-c C-c and C-u C-c C-c, with
and without an existing *Python*). I also tried with your command args
(although I'm running ipython 0.6.5).

> I'm pretty sure I'm running the new ipython.el, and I'm using
> python-mode revision 4.70 from CVS.


More information about the IPython-user mailing list