[IPython-user] ipython installation

Fernando Perez Fernando.Perez at colorado.edu
Sun Dec 31 19:14:34 CST 2006

Hi Andreas,

I'm cc-ing the ipython user list, where these questions are best discussed so 
others can provide feedback and the answers are publicly archived.

Andreas Grimm wrote:
> Hi Fernando, 
> I write you, because I have difficulties installing ipython 0.7.3. After unzipping the package I tried to execute setup.py, but he doesn't find a module. I get the following output:
> Traceback (most recent call last):
>   File "setup.py", line 18, in ?
>     from setupext import install_data_ext
>   File "/home/a-raas/quellcode/ipython-0.7.3/setupext/__init__.py", line 3, in ?
>     from install_data_ext import install_data_ext
>   File "/home/a-raas/quellcode/ipython-0.7.3/setupext/install_data_ext.py", line 7, in ?
>     from distutils.command.install_data import * #install_data
> ImportError: No module named distutils.command.install_data
> Do I have to download another file file first or can you advise me, what to do on this error ? I tried version 7.2, too and get the same error. 
> Thanks in advance and Merry Christmas, 
> Andreas Grimm

That's extremely strange.  The failing line in the traceback works under all 
reasonable versions of Python (at least those supported by ipython):

longs[~]> python2.3 -c 'from distutils.command.install_data import *'
longs[~]> python2.4 -c 'from distutils.command.install_data import *'
longs[~]> python2.5 -c 'from distutils.command.install_data import *'

Are you using some other version of Python?  If so, you should note that 
ipython only works with these three versions of Python, not any earlier one.

Otherwise, I'd suspect that you may have a broken Python installation, because 
  distutils is part of the standard library.  I just can't see another 



More information about the IPython-user mailing list