[IPython-user] auto_edit problems

Fernando Perez Fernando.Perez at colorado.edu
Tue Jan 31 13:36:34 CST 2006

Dave wrote:
> I still get "Return to editor to correct syntax error? [Y/n]  n" messages
> when I have syntax errors since upgrading to 0.7.0.  The 0.7.1 version seems
> to do the same thing. I added
> autoedit_syntax 0
> to my startup file (ipythonrc.ini) but still get the message.
> I'm running on WIN XP.
> Would love to turn this off since it is not of much help when you have an
> external editor already open for the file.
> Is there a simple edit I can do to a ipython module to disable this for now?

Mmh, that's very strange: the setting is honored for me:

In [8]: __IP.rc.autoedit_syntax=0

In [9]: edit
IPython will make a temporary file named: /tmp/ipython_edit_rnvW85.py
    File "/tmp/ipython_edit_rnvW85.py", line 1
      12qsda f
SyntaxError: invalid syntax

WARNING: Failure executing file: </tmp/ipython_edit_rnvW85.py>
  done. Executing edited code...
Out[9]: '12qsda f\n'

Try typing %config to see your config settings, and check that it's really 
being picked up as '0'.  Also try resetting it at runtime as above, and see if 
it helps.  Basically we need to clarify whether the problem is with the 
ipython internals, or whether you are picking up a different config from 



More information about the IPython-user mailing list