[IPython-user] ipython.el / xemacs / mac os x question

belinda thom bthom at cs.hmc.edu
Tue Nov 21 12:05:39 CST 2006


Your advice was spot-on, with one additional subtlety. I was using  
the carbon variant of XEmacs, which hangs when you try and attach  
gnuclient to it :-(. Someone posted a fix for this (http://off.net/ 
diary/2006/05/10/gnuclient-with-carbon-xemacs/)---some .c and .el  
code needs to be modified and then the whole thing rebuilt---but I  
haven't tried that. Went back to using X11 xemacs on the Mac, and  
things are mostly working now.



On Nov 21, 2006, at 6:29 AM, Jouni K Seppanen wrote:

>   [Sorry if this is a duplicate; I sent essentially the same message
>   yesterday, but it didn't seem to make it to the list.]
> belinda thom <bthom at cs.hmc.edu> writes:
>> 1) access python help via xmeacs via py-shell buffer. I've taken care
>> to set PYTHONDOCS. Running ipython from a terminal window works:
> [...]
>> but from an xeamcs py-shell buffer it does not:
>> In [1]: Help('If')
>> In [2]: print os.getenv('PYTHONDOCS')
>> None
> You have probably set PYTHONDOCS in one of your shell's dotfiles, and
> it is not inherited by the XEmacs you start from outside the shell.
> You could try to:
>  1) add (setenv "PYTHONDOCS" "/Users/bthom/Documents/Python- 
> Docs-2.4.3")
>     to your .xemacs/init.el
>  2) create a ~/.MacOSX/environment.plist file; see
>     http://developer.apple.com/qa/qa2001/qa1067.html
>  3) if you use SSHKeyChain, modify the environment using it
>     (I think this just modifies the environment.plist file)
>> Return to editor to correct syntax error? [Y/n]  Y
>> E437: terminal capability "cm" required
> This happens to me if I run M-x shell in XEmacs and start up vi within
> the shell. Funnily, it first complains about the terminal but then
> starts up anyway. Somehow you'll have to tell ipython to use the same
> XEmacs as the editor; hopefully someone on this list is more
> knowledgeable about ipython.el than I am. (Perhaps just set the editor
> to gnuclient?)
>> I get something similar when I try and run %edit: the "cm" complaint.
>> When this complaint is issued, I've not figured out how to recover; I
>> end up killing py-shell and restarting.
> If it is indeed vi that starts up, try typing :q! and Enter.
> -- 
> Jouni

More information about the IPython-user mailing list