[IPython-user] threading and ipython -pylab problem

Gabriel Beckers beckers@orn.mpg...
Tue Nov 4 10:36:35 CST 2008

No, unfortunately still the same. But I may have a clue: before
executing the lines in my previous mail, I run a script to facilitate
some analyses I want to do. I forgot about that, sorry. In this script I
use (or at least import) Enthought modules (traits, chaco etc.) and wx.
I think this has something to do with it, because I can't reproduce the
problem anymore if I don't run that script (I thought I did try that
before, but perhaps not).

The stuff that is imported (among others):

import wx
from enthought.chaco.api import ArrayDataSource, DataRange1D, LinePlot,
     FilledLinePlot, BarPlot, ScatterPlot, LinearMapper,
add_default_grids, PlotAxis, \
     GridPlotContainer, ArrayPlotData, create_scatter_plot,
ArrayPlotData, jet, Plot, \
     GridDataSource, DataRange2D, GridMapper, ImageData, ImagePlot
from enthought.chaco.tools.api import PanTool, ZoomTool, BroadcasterTool
from enthought.enable.api import Window
from enthought.kiva import CompiledPath

Probably the wx is not a good idea?


On Tue, 2008-11-04 at 17:57 +0200, Ville M. Vainio wrote:
> On Tue, Nov 4, 2008 at 5:55 PM, Gabriel Beckers <beckers@orn.mpg.de> wrote:
> > If I start ipython -pylab, pylab.rcParams contains 'backend': 'GTKAgg'.
> > I appended the output when building matplotlib below.
> Ah! I have probably fixed this in my branch. Please try:
> bzr branch lp:~villemvainio/ipython/trunk-dev

More information about the IPython-user mailing list