[IPython-user] ipython problem on OS X leopard: non-responsive "u" key.

Barry Wark barrywark@gmail....
Wed Oct 8 12:06:25 CDT 2008


As a fellow OS X & ipython user, I'm sorry you're struggling with
this. There was a discussion a while back about a similar sounding
issue. My recollection is that it was solved by removing the
~/.ipython directory and starting over. However, it sounds from some
of your other posts that you may not be using the system python that
shipped with Leopard (which uses libedit instead of GNU readline and
has thus been the source of some now hopefully resolved issues). What
do you get if you type "which python" at the command prompt? If it's
the Fink or MacPorts or MacPython python, there may be some issue with
their configuration. Do you have the same problem with any other
python programs (e.g. at the normal python prompt)? You may want to
try the "pythonmac-sig" list for help in that case.

I know you've gotten a lot of conflicting advice about which python
distribution to use. Just for completeness, let me add my 2 cents and
take it as you will: unless you have need for python 2.6 (keeping in
mind that neither IPython nor NumPy/SciPy officially support 2.6 yet),
stick with the system-installed python on Leopard and delete all of
the other distributions. Use setuptools to install packages and there
won't be any conflicts between system tools and your newly installed
packages (you can use distutils as well, but the newly installed
packages will be placed _after_ the system-installed packages on the
python path). This is the Apple-sanctioned and blessed way to do
Python on OS X. As a benefit of using the system python, you gain
Dtrace support in the python interpreter (without applying a patch and
recompiling the python distribution yourself). You can then use
Apple's Instruments application (or dtrace at the command line) to
profile and trace executing python code. It's very cool.

Finally, please keep asking questions on the list. There is a pretty
large community of IPython users on the Mac. Unfortunately I (and I
imagine others) can get pretty bogged down at work and our response
time on the list suffers. Please don't take it personally or as a
criticism of your question. If you have an issue that is also possibly
a bug in IPython (as this may be), please file a bug report at


On Tue, Oct 7, 2008 at 6:43 PM, Gary Church <gary.church1@comcast.net> wrote:
> Hello ipython users,
> I recently queried the list for help on a particularly annoying
> problem with ipython on OS X leopard. When I start ipython from a
> terminal (I use iterm but have tried in regular term as well)
> everything works fine except for the lower-case "u" key, which is
> unresponsive; nothing happens in iterm and I get a "beep" in term.
> A kind list-dweller tried helping with some suggestions but, alas, the
> problem remains. This seems strange to me as all other functionality
> (TAB completion, etc...) is present.
> If there are ipython, OS X leopard users on this list that aren't
> having any problems with ipython, maybe you could shed some light on
> my problem? I'm not sure where to start looking for a resolution so
> any suggestions are welcome :-)
> Thanks much,
> Gary
> Gary Church
> gary.church1@comcast.net
> _______________________________________________
> IPython-user mailing list
> IPython-user@scipy.org
> http://lists.ipython.scipy.org/mailman/listinfo/ipython-user

More information about the IPython-user mailing list