[IPython-user] Starting wx python apps

Gökhan SEVER gokhansever@gmail....
Fri Jun 26 15:44:08 CDT 2009

On Fri, Jun 26, 2009 at 3:29 PM, Dennis Muhlestein

>  Interesting.
>> On my Fedora, plot doesn't block the Ipython entry. They happily live by
>> eachother.
>> One thing I modified in the Shell.py (inside IPython folder) is to make
>> sure that I am always starting with pylab:
>>     #user_opts = set([s.replace('-','') for s in argv[:3]])
>>     user_opts = set(['pylab'])
>> Could you try with this?
> I didn't modify this file, but I'm pretty sure this would cause the Show
> function to not block since if I start ipython with -pylab, I can verify the
> non-blocking feature.
> My problem is that -pylab and -wthread don't work the same way.
> ipython -pylab pylab_script.py # __doesn't__ block
> ipython -wthread wx_script.py # __does__ block
> It would be nice if -wthread worked the same as -pylab
> -Dennis

I see your point now.

wthread switch blocks the execution somehow, however q4thread works well.

There should be some internal differences between the backends that is
causing this issue.

And a very interesting observation if I run the following lines with

import matplotlib.pyplot as plt
import numpy as np

a = np.linspace(0,2*np.pi, 1000)

I see the contents listed on whos, but get a empty namespace if I try the
same thing with wthread.

One additional comment: The ipy.py script was explicitly calling the ipython
from within a regular python script. I might not need to this if my scripts
load into an Ipython workspace with just a ipython script.py notation
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20090626/35f16292/attachment.html 

More information about the IPython-user mailing list