[IPython-user] Unable to get MPI examples to work

Brian Granger ellisonbg.net@gmail....
Wed Nov 18 12:30:49 CST 2009

I think the issue is that example was written using an older version of
mpi4py.  The docs have been updated
to reflect newer versions of mpi4py here:


Can you give this a shot?



On Tue, Nov 17, 2009 at 11:09 AM, Victor Hwang <psycovic@gmail.com> wrote:

> Hi,
> I have a network of 16 computation nodes set up with one main supervisor
> node.  I've installed mpi4py and iPython on all of them. Here are the steps
> I run to get things going:
> on supervisor:
> $ ipcontroller
> then I get the ipcontroller-engine.furl to all the nodes. Then, on each
> nodes, I run:
> mpiexec -n 1 ipengine --mpi=mpi4py --furl-file=/location/of/file
> I can control all of these engines from the supervisor on iPython, but when
> I run the psum example (
> http://ipython.scipy.org/doc/manual/html/parallel/parallel_mpi.html#actually-using-mpi), the returned results I get from each node don't agree with each other.  I
> followed the listed commands exactly.  Any ideas?
> _______________________________________________
> IPython-user mailing list
> IPython-user@scipy.org
> http://mail.scipy.org/mailman/listinfo/ipython-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20091118/ed94e65d/attachment.html 

More information about the IPython-user mailing list