[IPython-User] problems with ipython 0.10 autocompletion and interactive plotting

Ryan Krauss ryanlists@gmail....
Wed Aug 11 09:10:49 CDT 2010

I am sorry to send you so many emails on this subject.  I asked the
question about show() blocking execution on the matplotlib mailing
list.  Apparently, this is a known issue that has been fixed in svn.

On Tue, Aug 10, 2010 at 10:40 PM, Ryan Krauss <ryanlists@gmail.com> wrote:
> My suspicion is that the blocking of show is really a matplotlib
> problem.  It seems that there were major changes to the behavior of
> show in matplotlib 1.0.0.  But I don't think what we are seeing is
> what is supposed to happen.
> Ryan
> On Tue, Aug 10, 2010 at 7:37 PM, Ryan Krauss <ryanlists@gmail.com> wrote:
>> In the distant past, TkAgg matplotlib backend solved any issues like
>> this.  That is not the case for me currently.
>> On Tue, Aug 10, 2010 at 2:23 PM, Ryan Krauss <ryanlists@gmail.com> wrote:
>>> I have the same problem with having to close the plots when running a
>>> script after a recent install in Windows XP.  I suspect that changing
>>> the default matplotlib backend may solve this problem, but I haven't
>>> tried it yet.  It would be great if there was some other solution that
>>> just worked out of the box.
>>> Ryan
>>> On Sat, Jul 31, 2010 at 5:23 AM, Daniel Platz
>>> <mail.to.daniel.platz@googlemail.com> wrote:
>>>> Hello!
>>>> I have some problems with ipython which I do not really understand, I
>>>> installed ipython 0.10 together with Python 2.6 on Windows 7. This
>>>> installation was no problem and I can also run ipython. However, there
>>>> are two problems.
>>>> The autocompletion seems not to work with external packages. For
>>>> example, if I use the pylab option, type "l" and press tab nothing
>>>> happens. It seems that only when there is one possibility left the
>>>> completion works, i.e. it completes "linspa" to "linspace". So it does
>>>> not show other options for completion.
>>>> The second problem concerns plotting with matplotlib. From the shell I
>>>> can plot as usually. When I run a script with some plotting commands,
>>>> ipython does not return from a "show" command. Instead I have to close
>>>> the plot window and then I can use ipython again.
>>>> I looked into the documentation but I have no idea what these problems
>>>> can really be due to. I am thinking that it could be a problem that I
>>>> run windows 7 with 64 bit. But I have the same setup running on
>>>> another windows 7 64 bit computer and there it works like a charm.
>>>> Could there be a problem with pyreadline? How can I check this? Or
>>>> went something wrong during the configuration in the first ipython
>>>> run? I would be very glad if someone has an idea about the described
>>>> problems.
>>>> Thanks in advance
>>>> Daniel
>>>> _______________________________________________
>>>> IPython-User mailing list
>>>> IPython-User@scipy.org
>>>> http://mail.scipy.org/mailman/listinfo/ipython-user

More information about the IPython-User mailing list