[IPython-User] Notebook: console is not defined

klo uo klonuo@gmail....
Wed Feb 1 07:33:35 CST 2012

Thanks for explanation. I had no idea about what websockets is, so I
googled and get rough picture

I commented "console" lines in notebook.js and managed to open saved
IPython notebook, but then dialog popped about missing websockets :D

I also tried https://github.com/mozilla/chromeless (Python wrapped)
with xulrunner 9, and when I opened IPython notebook and selected
saved notebook, I didn't get dialog about missing websockets, but just
blank page. From what I've read in the meantime seems like websockets
is included since Firefox 4, so xulrunner 9 most definitely should
have this feature, but I'm not sure if I'm talking apples and oranges.
I'll try later today again to see if I can get notebook running with

My problem is old PC - 2GB, 3GHz P4 (which I can't upgrade soon) and
when I run notebook with pylab I get famous "heartbeat stopped -
kernel died" or similar message on startup (usually) and I looked for
other way to use this feature.

More information about the IPython-User mailing list