[IPython-User] ipython qtconsole segmentation fault when displaying calltips / tooltips?

Stefan shmueller2@gmail....
Wed Feb 15 15:34:28 CST 2012


I am experiencing a problem with ipython qtconsole on Mac OS X: 

Sometimes hitting "(" results in a segmentation fault rather that a tooltip
being displayed. 
For example, in a fresh "ipython qtconsole":

import scipy.sparse.linalg
scipy.sparse.linalg.spsolve(  -> segmentation fault after hitting "("


from scipy.sparse.linalg import spsolve
spsolve( -> tooltip is correctly displayed


from mayavi.sources.api import ArraySource
ArraySource( -> SegFault after hitting "("

Googling didn't provide any useful information.

So I suspected PyQt and tried upgrading PyQt from version 4.9.0 to 4.9.1, as
well as replacing PyQt4 with pyside. 
This didn't resolve the issue. (ipython qtconsole started in all
My configuration is:    (installed by homebrew and pip)

- MacOSX 10.7.2 (Lion)
- Python 2.7.2
- ipython 0.12
- Qt 4.8.0
- PyQt 4.9.1

I also tried ipython 0.11 and ipython 0.13.dev, but couldn't get the
qtconsole to work at all with either.

Anyone experiencing the same issue? Any ideas what could cause it?

Also, is there a way to switch off the tooltips on typing "(", so I can work
for now? 
I am using the shell ipython for now, but it becomes very unresponsive after
importing anything from mayavi. 
The qtconsole remains nice and snappy, but it's not much use if it crashes
everytime I hit "(" ...

Many thanks for your ideas,


View this message in context: http://python.6.n6.nabble.com/ipython-qtconsole-segmentation-fault-when-displaying-calltips-tooltips-tp4474019p4474019.html
Sent from the IPython - User mailing list archive at Nabble.com.

More information about the IPython-User mailing list