[IPython-User] Getting matplotlib output using %run in qtconsole

Sean Vig sean.v.775@gmail....
Thu Jan 5 10:22:46 CST 2012


I'm trying to generate a script to quickly check that some sympy latex
output is correctly rendered in the Qt console (see the work at [1]), but
I'm unable to get any matplotlib output. I worked up an html notebook to
check the MathJax rendering, and used the notebook to output that script as
a py file, then tried to %run the file, but I don't get any matplotlib
output (or any output at all). I've created and attached a simple example
ipynb and corresponding py file to show what I'm doing. I'm working off the
latest git version of ipython. Any help to get this working would be
greatly appreciated.


[1] https://github.com/sympy/sympy/pull/908
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20120105/29296018/attachment.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test sympy.ipynb
Type: application/octet-stream
Size: 1429 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/ipython-user/attachments/20120105/29296018/attachment.obj 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test sympy.py
Type: text/x-python
Size: 150 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/ipython-user/attachments/20120105/29296018/attachment.py 

More information about the IPython-User mailing list