[IPython-User] No response to client from ipcontroller

Adam Davis addavis@fosterandpartners....
Mon Jan 30 12:17:08 CST 2012

I have succesfully run ipcluster for a function defined with the
@lview.parallel decorator on a single host. I am trying to run the
ipcontroller / ipengine set up on this same host as a first step in
testing on multiple hosts. However, the controller doesn't seem to
respond to the Client instance in my python code.

I get the following (excerpted) messages in the ipcontroller log:

	2012-01-30 11:35:57.752 [IPControllerApp] client::client
'6142679f-36ad-4876-a096-ecbe675a9a3f' requested 'registration_request'
	2012-01-30 11:35:57.752 [IPControllerApp]
registration::register_engine(0, '6142679f-36ad-4876-a096-ecbe675a9a3f',
	2012-01-30 11:35:58.752 [IPControllerApp] heartbeat::sending
	2012-01-30 11:35:59.752 [IPControllerApp] heartbeat::sending
	2012-01-30 11:35:59.752 [IPControllerApp]
	2012-01-30 11:35:59.752 [IPControllerApp] registration::finished
registering engine 0:'6142679f-36ad-4876-a096-ecbe675a9a3f'
	2012-01-30 11:35:59.752 [IPControllerApp] engine::Engine
Connected: 0

	2012-01-30 11:36:07.548 [IPControllerApp] client::client
'56566026-4447-442d-8607-f1b00f9740a6' requested 'registration_request'
	2012-01-30 11:36:07.548 [IPControllerApp]
registration::register_engine(1, '56566026-4447-442d-8607-f1b00f9740a6',
	2012-01-30 11:36:07.766 [IPControllerApp] heartbeat::sending
	2012-01-30 11:36:08.766 [IPControllerApp] heartbeat::sending
	2012-01-30 11:36:08.766 [IPControllerApp]
	2012-01-30 11:36:08.766 [IPControllerApp] registration::finished
registering engine 1:'56566026-4447-442d-8607-f1b00f9740a6'
	2012-01-30 11:36:08.766 [IPControllerApp] engine::Engine
Connected: 1

... that lead me to believe all is ok with the Engines establishing
connection to the controller.

Subsequently, I get the following when my client code connects:

	2012-01-30 11:36:59.094 [IPControllerApp] client::client
'186a760b-a105-4283-a5e3-a5f57feda744' requested 'connection_request'
	2012-01-30 11:36:59.094 [IPControllerApp] client::client
['186a760b-a105-4283-a5e3-a5f57feda744'] connected

However, where the ipcluster then returns the results and outputs log
messages like:

	2012-01-30 16:34:43.357 [IPControllerApp] task::task
'cf5dd2c6-94f9-4d7e-8df6-aadc9d3f5498' arrived on 1

	2012-01-30 16:34:44.795 [IPControllerApp] task::task
'cf5dd2c6-94f9-4d7e-8df6-aadc9d3f5498' finished on 1

... the ipcontroller/engine setup doesn't ever return results. I have
searched the mailing list archives and following this post:
http://mail.scipy.org/pipermail/ipython-user/2011-October/008530.html, I
tried invoking the ipcontroller as:

ipcontroller --ip=

I have also tried editing ipcontroller_config.py to listen on as
well, but the effect is the same in each case. Are there any obvious
things I may be doing incorrectly (or failing to do)? Otherwise, are
there further suggestions for debugging beyond what is available through
the controller and engine logs? Many thanks.


More information about the IPython-User mailing list