[IPython-User] IPython notebook produces no output on Windows 7

Alex alex.at.workplace@googlemail....
Tue Jul 10 09:10:32 CDT 2012

Hi Matthias,

thank you for your interest. I am still trying to debug the problem and 
have not been successful so far. Below I tried to follow your 
instructions and got a little further.

On 10.07.2012 10:29, Matthias BUSSONNIER wrote:
> Hi alexander,
> You should get smith like :
> [NotebookApp] Kernel started: af66e841-321b-4201-81e3-4bb40bb1b6f4
> [NotebookApp] Connecting to: tcp://
> [NotebookApp] Connecting to: tcp://
> [NotebookApp] Connecting to: tcp://
> when clicking on a notebook.

I clicked on a notebook after starting ipython and looked at the console 

C:\Temp>ipython notebook
[NotebookApp] Using existing profile dir: 
[NotebookApp] Serving notebooks from C:\Temp
[NotebookApp] The IPython Notebook is running at:
[NotebookApp] Use Control-C to stop this server and shut down all kernels.
[NotebookApp] Using MathJax from CDN: 
[NotebookApp] Kernel started: f7d147cb-898a-4d1d-a5a8-7a5edcee4be6
[IPKernelApp] To connect another client to this kernel, use:
[IPKernelApp] --existing kernel-f7d147cb-898a-4d1d-a5a8-7a5edcee4be6.json
[NotebookApp] Connecting to: tcp://

So, it seems something is started. Additionally after executing a line 
in the notebook the number in the prompt changes

In [3]: print("test")
<press CTRL+ENTER>
In [4]: print("test")

but I do not get any output or other changes. The console does not show 
any error messages either.

> this make me think that ws connexion never occurred.
> Do you have a proxy ?
I do not have a proxy configured in neither Chrome nor Firefox.

> You can try  `%qtconsole` in the notebook to get a console attached to the same kernel… but I doubt the command ever get to the kernel.
Oh, that was a good tip. I tried executing `%qtconsole` in the notebook 
and a console window appeared! I also tried to define a variable `a=5` 
in the notebook and I could access that variable in the other opened 
console windows. So some connection seems to exist but the notebook 
still does not show any output.

Anything else that I can try to get it to work?

Thanks for the feedback!

More information about the IPython-User mailing list