[IPython-User] matplotlib demo - unreadable json

Jonathan March jmarch@enthought....
Sun Oct 21 17:57:03 CDT 2012

On Fri, Oct 19, 2012 at 4:34 PM, ilanman <ilan.man@gmail.com> wrote:

> Hi there, I am getting the exact same error.
> When I launch "python notebook --pylab inline", everyone launches in my
> browser as its supposed to, but the notebook that I click on (which was in
> the directory from which I launed ipython notebook) is empty. There is no
> code there. My terminal yields that same error:
> Ilan-Mans-MacBook-Pro:04 ilanman$ ipython notebook --pylab inline
> [NotebookApp] Using existing profile dir:
> u'/Users/ilanman/.ipython/profile_default'
> [NotebookApp] The IPython Notebook is running at:
> [NotebookApp] Use Control-C to stop this server and shut down all kernels.
> [NotebookApp] Using MathJax from CDN
> WARNING:root:500 GET
> /notebooks/d479b1f0-d1af-4aea-80a1-280f9bfc379e?_=1350681835641
> (
> Unreadable JSON notebook.
> ERROR:root:500 GET
> /notebooks/d479b1f0-d1af-4aea-80a1-280f9bfc379e?_=1350681835641 (
> 56.46ms
> I just installed ipython via Enthought. I'm using Python 2.7.3. I'm not
> sure
> how to "use v2" instead of v3. I don't know where to direct it to "use" v2.
> Any help would be greatly appreciated

Hi Ilan, Yes, EPD 2.7.3 shipped with ipython 0.12.x
To update to 0.13:
$ enpkg enstaller
$ enpkg ipython
(precede these with sudo if you are on OSX, or installed to a
non-user-writeable dir in Linux)

Note that the ipython that you will get this way will say that it is
0.13.1-1. This is false; it is really 0.13. We plan to have ipython
0.13.1-2 egg available early this week, which really will be the
just-released 0.13.1.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-user/attachments/20121021/d1a51939/attachment.html 

More information about the IPython-User mailing list