[IPython-User] Ipython

Paul Ivanov pi@berkeley....
Thu Apr 4 14:18:54 CDT 2013

Guillermo Rangel, on 2013-04-04 11:11,  wrote:
> Hi Paul
> For some reason I was playing with NetworkX and I noticed I was getting a
> matplotlib problem about invalidate something I can't recall. I decided to
> easy_install -U matplotlib and my life completely change. I can't get any
> plots out of matplotlib now, actually when I start ipython notebook --pylab
> inline I get the gollowing message
> [IPKernelApp] GUI event loop or pylab initialization failed
> Also I tried to use the pylab magic and I get the same problem.
> I can't plot now. I've noticed this has happened before. I tried updating
> scipy as well to no avail. Could you please advice?

can you start the ipython notebook without any flags, and in a
new notebook just do %pylab inline, and provide the full

Also, did you verify that matplotlib actually still works (can
you still get plots using just plain python, for example)

I'm forwarding this conversation to the IPython user list, so
that someone else could pitch in with ideas, and can find
whatever workaround we find for this via a search engine at a
later time.

Paul Ivanov
http://pirsquared.org | GPG/PGP key id: 0x0F3E28F7

More information about the IPython-User mailing list